Recientemente fui como parte del staff de una expo a configurar la red de datos LAN y la salida a Internet el centro de exposiciones cambió sus políticas de acceso a Internet y ahora el acceso lo teniamos que hacer vía PPPoE y proveían únicamente el usuario y password para el acceso.
Como sabemos PPPoE (Point-to-Point Protocol over Ethernet o Protocolo Punto a Punto sobre Ethernet) es un protocolo de red para la encapsulación PPP sobre una capa de Ethernet. Es utilizada mayoritariamente para proveer conexión de banda ancha mediante servicios de cablemódem y DSL. Este ofrece la autentificar directamente sin necesidad de tener ningún parámetro IP configurado previamente.
Para la interconexión use un Router Cisco 871W y la versión IOS 12.4
La configuración fue la siguiente:
Building configuration...
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname COMTELSAT_Expo
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.200
!
ip dhcp pool LAN
network 10.10.10.0 255.255.255.0
default-router 10.10.10.254
dns-server 8.8.8.8 4.4.2.2
domain-name comtelsat.com
!
!
ip domain name *****.com
ip ssh version 2
vpdn enable
!
vpdn-group 1
request-dialin
protocol pptp
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Vlan1
description LAN
ip address 10.10.10.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer idle-timeout 180 either
dialer hold-queue 100
dialer-group 1
ppp chap hostname (username)
ppp chap password 0 (password)
ppp pap sent-username (username) password (password)
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
ip nat inside source list INT interface Dialer1 overload
!
ip access-list extended INT
permit ip any any
!
dialer-list 1 protocol ip permit
!
control-plane
!
!
line con 0
logging synchronous
login local
no modem enable
line aux 0
line vty 0 4
logging synchronous
login local
transport input ssh
!
scheduler max-task-time 5000
end
Como sabemos PPPoE (Point-to-Point Protocol over Ethernet o Protocolo Punto a Punto sobre Ethernet) es un protocolo de red para la encapsulación PPP sobre una capa de Ethernet. Es utilizada mayoritariamente para proveer conexión de banda ancha mediante servicios de cablemódem y DSL. Este ofrece la autentificar directamente sin necesidad de tener ningún parámetro IP configurado previamente.
Para la interconexión use un Router Cisco 871W y la versión IOS 12.4
La configuración fue la siguiente:
Building configuration...
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname COMTELSAT_Expo
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.200
!
ip dhcp pool LAN
network 10.10.10.0 255.255.255.0
default-router 10.10.10.254
dns-server 8.8.8.8 4.4.2.2
domain-name comtelsat.com
!
!
ip domain name *****.com
ip ssh version 2
vpdn enable
!
vpdn-group 1
request-dialin
protocol pptp
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Vlan1
description LAN
ip address 10.10.10.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer idle-timeout 180 either
dialer hold-queue 100
dialer-group 1
ppp chap hostname (username)
ppp chap password 0 (password)
ppp pap sent-username (username) password (password)
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
ip nat inside source list INT interface Dialer1 overload
!
ip access-list extended INT
permit ip any any
!
dialer-list 1 protocol ip permit
!
control-plane
!
!
line con 0
logging synchronous
login local
no modem enable
line aux 0
line vty 0 4
logging synchronous
login local
transport input ssh
!
scheduler max-task-time 5000
end
Comentarios
Publicar un comentario