Este es el ejemplo básico de iBGP en el cual se interconectan 3 sitios con su propio AS, la configuración permite que la ruta por defecto del router INET sea heredada a la tabla de ruteo de los routers ISP_A e ISP_B permitiendo la salida a internet, fue necesario configurar NAT.
El esquema de interconexión es el siguiente:
Las configuraciones de los equipos son:
INET:
interface Loopback0
description ID
ip address 1.1.1.4 255.255.255.255
!
interface GigabitEthernet0/0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex full
speed 1000
media-type gbic
negotiation auto
!
interface FastEthernet1/0
description TO_ISP_1
ip address 100.100.100.1 255.255.255.252
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1/1
description TO_ISP_2
ip address 200.200.200.1 255.255.255.252
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
router bgp 4000
no synchronization
bgp log-neighbor-changes
network 1.1.1.4 mask 255.255.255.255
neighbor 100.100.100.2 remote-as 1000
neighbor 100.100.100.2 default-originate
neighbor 200.200.200.2 remote-as 2000
neighbor 200.200.200.2 default-originate
no auto-summary
!
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 192.168.40.1
!
access-list 1 permit 100.100.100.0 0.0.0.3
access-list 1 permit 200.200.200.0 0.0.0.3
ISP_A:
interface Loopback0
description ID
ip address 1.1.1.1 255.255.255.255
interface FastEthernet1/0
description TO_INET
ip address 100.100.100.2 255.255.255.252
duplex auto
speed auto
router bgp 1000
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
neighbor 100.100.100.1 remote-as 4000
no auto-summary
ISP_B:
interface Loopback0
description ID
ip address 1.1.1.2 255.255.255.255
interface FastEthernet0/1
description TO_INET
ip address 200.200.200.2 255.255.255.252
duplex auto
speed auto
router bgp 2000
no synchronization
bgp log-neighbor-changes
network 1.1.1.2 mask 255.255.255.255
neighbor 200.200.200.1 remote-as 4000
no auto-summary
Comentarios
Publicar un comentario